lunes, 29 de octubre de 2007

Asociar enlaces ed2k entre Firefox y aMule en Ubuntu (actualizado)

Si quieres que al pulsar dentro de una página web sobre un enlace ed2k (también llamado elink), éste se añada automáticamente a las descargas de nuestro aMule, tenemos que instalar un paquete, a mayores del paquete amule, además de añadir dos nuevas entradas a la lista de configuraciones de Firefox. Dicho paquete a instalar dependerá de si usamos la versión 2.1.3 de aMule, o la nueva versión (todavía en desarrollo) 2.2.0 (recomendada). A continuación te lo explico paso a paso:

1.-Instala el paquete que corresponda a tu versión de amule:

* amule-utils (no confundir con amule-utils-gui) en caso de que usemos la versión 2.2.0
* amule-ed2k en caso de que usemos la versión 2.1.3

2.-Ejecuta Firefox. En la barra de direcciones, escribe about:config y pulsa intro (mira la última captura de esta entrada).

3.-Pulsa botón derecho sobre cualquier elemento de la lista, y en el menú de contexto, selecciona la opción Nuevo -> Lógico. En la pantalla que se abre, escribe (mejor aún, pega) en el campo nombre:

network.protocol-handler.external.ed2k

y true como valor (si no te pregunta el valor, haz doble clic sobre la entrada que acabamos de crear para cambiar su estado de false a true).


4.-De nuevo clic derecho sobre cualquier entrada y selecciona Nuevo -> Cadena en el menú y escribe como nombre:

network.protocol-handler.app.ed2k

y como valor la ruta donde tienes instalado el paquete ed2k, que en Ubuntu, es

/usr/bin/ed2k

Una vez seguidos todos los pasos, al hacer clic sobre un elink, éste se añadirá automáticamente en tu aMule.

5 comentarios:

MouTio dijo...

Hola, en primer lugar quería agradecerte la entrada del blog. Me ha servido de gran ayuda con la versión 2.1.3 de aMule. Hoy me he decidido por pasarme a la versión de desarrollo, pero he tenido un problema. El amule-ed2k no lo encuentra en los repositorios.

¿Hay que descargarlo de alguna otra parte?

Gracias

jmunin dijo...

En teoría va incluido dentro del propio paquete del aMule, pero todo depende de quien prepare dicho paquete. Si estás usando x/k/ubuntu, prueba con los paquetes del siguiente enlace que prepara 'Festor' para distintas versiones (gutsy, feisty, etc):
http://forum.amule.org/index.php?PHPSESSID=df47b177fc38120ef6b3471991a472a3&board=70.0
Espero te sirva de ayuda ;-)

Antonio dijo...

Me ha resultado muy útil, gracias y enhorabuena por la página.

Un saludo.

googilto dijo...

A mi no me funciona. No da ningun error pero no hace nada.
Usais amule-daemon, verdad?

jmunin dijo...

Hola googilto...

Realemente no lo he probado con amule-daemon. ¿Qué distro usas? ¿Qué versión de la misma? ¿Qué versión de amule, y de qué fuente? Dame alguna pista... ;-)

Con Ubuntu Hardy 8.04.1 y los paquetes de amule 2.2.2 obtenidos de http://www.getdeb.net funciona sin problemas